Bing blogs

This is a place devoted to giving you deeper insight
into the news, trends, people and technology behind Bing.

Sitemap not accepted

Webmaster

Webmaster
This group is devoted to Bing Webmaster Tools discussions.

Sitemap not accepted

This question is not answered

Hello-

 

I've been trying to submit my sitemap - www.mydomain.com/sitemap.xml to Bing but it keeps saying Type: unknown and Status: Error. I am using the same sitemap.xml file I submitted to Google with no problem. Everything I read says that Bing accepts sitemaps in this format.

 

Can someone help me figure this out?

 

Thanks!
David 

All Replies
  • What error exactly are you  getting from bing?

  • It is not giving me a specific error. Under the column, "Status" it just says error and in the "type" column it just says invalid. It is the same exact sitemap I uploaded to Google.

  • Can post your sample sitemap format? that you submitted to bing

    johnny

    Findur

  •  

    Hi,

     

    I suggest you review the sitemap through http://www.validome.org/xml/validate/ and perform corrective changes as necessary.

     

    The following links can also be used for your reference with Sitemaps XML file:

    Sitemaps XML format

    http://www.sitemaps.org/protocol.php

     

    Introducing Schema.org: Bing, Google and Yahoo Unite to Build the Web of Objects

    http://www.bing.com/community/site_blogs/b/search/archive/2011/06/02/bing-google-and-yahoo-unite-to-build-the-web-of-objects.aspx

     

    http://www.sitemaps.org/protocol.php

    Thanks,

  • Thanks to JayGon down here, pointing people in the right direction, thanks Jay !

    More than one would like to know why a google sitemap does not work in Bing. This is what I found if it helps anyone, I know may sound silly to many of you, but there is other bunch stuck due this silly thing:

    1) Google is flexible when reads the XML regardless of possition of field, Bing not, likes only proper order of fields (pledged to the specific schema.org)

    2) Google accepts two decimals in the priority, schema.org just accept 0.1 to 1.0 (one decimal)

    So basically what I needed to do was: Make sure fields are in this order as in schema.org

    (I had <changefreq> after <priority> as many people that built their sitemaps long ago)

    Here is a sample of a sitemap, corrected and validated:

    (that the URL must be yours, and syntax is always in encoded characters)

    <?xml version="1.0" encoding="UTF-8"?>

    <urlset  xmlns="www.sitemaps.org/.../0.9"  

         xmlns:xsi="www.w3.org/.../XMLSchema-instance"  

         xsi:schemaLocation="www.sitemaps.org/.../0.9  

             www.sitemaps.org/.../sitemap.xsd">

    <url>

     <loc>www.yourdomain.com/page

     <lastmod>2012-11-01T18:04:02+00:00</lastmod>

      <changefreq>weekly</changefreq>

      <priority>0.5</priority>

    </url>

    </urlset>

  • Update on las port (characters are cuttend in the sample).

    Regardlesis valid according http://www.validome.org/xml/validate/ it does not work for bing... still rejecting all

    <?xml version="1.0" encoding="UTF-8"?>
    <urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://www.sitemaps.org/schemas/sitemap/0.9
    http://www.sitemaps.org/schemas/sitemap/0.9/sitemap.xsd">
    <url>
    <loc>http://www.domain.com/page.asp</loc>
    <lastmod>2012-11-02T18:04:02+00:00</lastmod>
    <changefreq>weekly</changefreq>
    <priority>0.5</priority>
    </url>
    </urlset>
  • Update on las port (characters are cuttend in the sample).

    Regardlesis valid according http://www.validome.org/xml/validate/ it does not work for bing...

    <?xml version="1.0" encoding="UTF-8"?>
    <urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://www.sitemaps.org/schemas/sitemap/0.9
    http://www.sitemaps.org/schemas/sitemap/0.9/sitemap.xsd">
    <url>
    <loc>http://www.domain.com/page.asp</loc>
    <lastmod>2012-11-02T18:04:02+00:00</lastmod>
    <changefreq>weekly</changefreq>
    <priority>0.5</priority>
    </url>
    </urlset>
  • Are you sure your sitemap.xsd stylesheet file does exist and is located in the same directory as sitemap.xml?

  • www.mydomain.com/sitemap.xml   SYNTAX IS WROG IN BING BUT IT IS TRUE IN GOOGLE.

    THE CORECT ANSWER IS

    www.mydomain.com